- Fix undefined warning in magick-type.h (#489453)
- Do not link PerlMagick against system ImageMagick, but against the just build oneepel8
parent
252b0ed307
commit
9aec96f364
@ -0,0 +1,12 @@
|
||||
diff -up ImageMagick-6.4.9-6/PerlMagick/Makefile.PL.in~ ImageMagick-6.4.9-6/PerlMagick/Makefile.PL.in
|
||||
--- ImageMagick-6.4.9-6/PerlMagick/Makefile.PL.in~ 2009-01-03 16:55:31.000000000 +0100
|
||||
+++ ImageMagick-6.4.9-6/PerlMagick/Makefile.PL.in 2009-03-13 11:22:46.000000000 +0100
|
||||
@@ -77,7 +77,7 @@ WriteMakefile
|
||||
'INSTALLBIN' => '@BIN_DIR@',
|
||||
|
||||
# Library specification
|
||||
- 'LIBS' => [ '-L@MAGICKCORE_PATH@ -L../magick/.libs -lMagickCore -L../wand/.libs -lMagickWand -lperl @MATH_LIBS@' ],
|
||||
+ 'LIBS' => [ '-L../magick/.libs -lMagickCore -L../wand/.libs -lMagickWand -lperl @MATH_LIBS@' ],
|
||||
|
||||
# Perl binary name (if a Perl binary is built)
|
||||
'MAP_TARGET' => 'PerlMagick',
|
@ -0,0 +1,12 @@
|
||||
diff -up ImageMagick-6.4.9-6/magick/magick-type.h~ ImageMagick-6.4.9-6/magick/magick-type.h
|
||||
--- ImageMagick-6.4.9-6/magick/magick-type.h~ 2009-01-15 03:13:58.000000000 +0100
|
||||
+++ ImageMagick-6.4.9-6/magick/magick-type.h 2009-03-13 10:30:59.000000000 +0100
|
||||
@@ -127,7 +127,7 @@ typedef unsigned __int64 MagickSizeType;
|
||||
#define MagickSizeFormat "%10llu"
|
||||
#endif
|
||||
|
||||
-#if _MSC_VER == 1200
|
||||
+#if defined(_MSC_VER) && (_MSC_VER == 1200)
|
||||
typedef MagickOffsetType QuantumAny;
|
||||
#else
|
||||
typedef MagickSizeType QuantumAny;
|
Loading…
Reference in new issue