parent
ad4194be12
commit
28b451accf
@ -0,0 +1 @@
|
||||
/FAudio-19.02.tar.gz
|
@ -0,0 +1,28 @@
|
||||
--- a/CMakeLists.txt 2019-01-30 08:37:10.000000000 -0600
|
||||
+++ b/CMakeLists.txt 2019-02-28 15:49:07.218026681 -0600
|
||||
@@ -17,6 +17,12 @@
|
||||
option(INSTALL_MINGW_DEPENDENCIES "Add dependent libraries to MinGW install target" OFF)
|
||||
endif()
|
||||
|
||||
+# Version
|
||||
+SET(LIB_MAJOR_VERSION "0")
|
||||
+SET(LIB_MINOR_VERSION "19")
|
||||
+SET(LIB_REVISION "02")
|
||||
+SET(LIB_VERSION "${LIB_MAJOR_VERSION}.${LIB_MINOR_VERSION}.${LIB_REVISION}")
|
||||
+
|
||||
# Build Type
|
||||
if(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
|
||||
# By default, we use Release
|
||||
@@ -103,6 +109,12 @@
|
||||
target_link_libraries(FAudio PRIVATE -static-libgcc)
|
||||
endif()
|
||||
|
||||
+# Soname
|
||||
+set_target_properties(FAudio PROPERTIES OUTPUT_NAME "FAudio"
|
||||
+ VERSION ${LIB_VERSION}
|
||||
+ SOVERSION ${LIB_MAJOR_VERSION}
|
||||
+)
|
||||
+
|
||||
# XNA_Song Support
|
||||
if(XNASONG)
|
||||
target_sources(FAudio PRIVATE src/XNA_Song.c)
|
@ -0,0 +1,80 @@
|
||||
Name: FAudio
|
||||
Version: 19.02
|
||||
Release: 1%{?dist}
|
||||
Summary: FNA is a reimplementation of the Microsoft XNA Game Studio 4.0 Refresh libraries
|
||||
|
||||
License: zlib
|
||||
URL: https://fna-xna.github.io/
|
||||
Source0: https://github.com/FNA-XNA/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
|
||||
# https://github.com/FNA-XNA/FAudio/issues/115
|
||||
Patch0: FAudio-soname.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
||||
BuildRequires: SDL2-devel
|
||||
|
||||
|
||||
%description
|
||||
This is FAudio, an XAudio reimplementation that focuses solely on developing
|
||||
fully accurate DirectX Audio runtime libraries for the FNA project, including
|
||||
XAudio2, X3DAudio, XAPO, and XACT3.
|
||||
|
||||
|
||||
%package -n libFAudio
|
||||
Summary: %{summary}
|
||||
|
||||
|
||||
%description -n libFAudio
|
||||
This is FAudio, an XAudio reimplementation that focuses solely on developing
|
||||
fully accurate DirectX Audio runtime libraries for the FNA project, including
|
||||
XAudio2, X3DAudio, XAPO, and XACT3.
|
||||
|
||||
|
||||
%package -n libFAudio-devel
|
||||
Summary: Development files for the FAudio library
|
||||
Requires: libFAudio%{?_isa} = %{version}-%{release}
|
||||
|
||||
|
||||
%description -n libFAudio-devel
|
||||
Development files for the FAudio library.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup
|
||||
|
||||
|
||||
%build
|
||||
%cmake .
|
||||
%make_build
|
||||
|
||||
|
||||
%install
|
||||
%make_install
|
||||
|
||||
|
||||
%files -n libFAudio
|
||||
%license LICENSE
|
||||
%doc README
|
||||
%{_libdir}/libFAudio.so.0*
|
||||
|
||||
|
||||
%files -n libFAudio-devel
|
||||
%{_libdir}/libFAudio.so
|
||||
%{_libdir}/cmake/FAudio/
|
||||
%{_includedir}/F3DAudio.h
|
||||
%{_includedir}/FACT.h
|
||||
%{_includedir}/FACT3D.h
|
||||
%{_includedir}/FAPO.h
|
||||
%{_includedir}/FAPOBase.h
|
||||
%{_includedir}/FAPOFX.h
|
||||
%{_includedir}/FAudio.h
|
||||
%{_includedir}/FAudioFX.h
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 28 2019 Michael Cronenworth <mike@cchtml.com> - 19.02-1
|
||||
- Initial spec file.
|
||||
|
Loading…
Reference in new issue