You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
25 lines
1.1 KiB
25 lines
1.1 KiB
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 8304f0d..88f0949 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -12,6 +12,11 @@ SET(CMAKE_CXX_FLAGS "-D NDEBUG -O3" )
|
|
ENDIF(CMAKE_COMPILER_IS_GNUCC)
|
|
ENDIF(NOT CMAKE_BUILD_TYPE)
|
|
|
|
+SET( charls_HEADERS "colortransform.h" "context.h" "decoderstrategy.h" "encoderstrategy.h" "interface.h"
|
|
+ "losslesstraits.h" "scan.h" "streams.h" "config.h" "contextrunmode.h" "defaulttraits.h"
|
|
+ "header.h" "lookuptable.h" "processline.h" "util.h" "publictypes.h"
|
|
+)
|
|
+
|
|
OPTION(charls_BUILD_SHARED_LIBS "Build CharLS with shared libraries." OFF)
|
|
SET(BUILD_SHARED_LIBS ${charls_BUILD_SHARED_LIBS})
|
|
|
|
@@ -21,3 +26,7 @@ add_library(CharLS header.cpp interface.cpp jpegls.cpp )
|
|
add_executable(charlstest test/main.cpp test/time.cpp test/util.cpp test/bitstreamdamage.cpp test/compliance.cpp test/performance.cpp test/dicomsamples.cpp)
|
|
target_link_libraries (charlstest CharLS)
|
|
|
|
+# Installs the header files into the {build_dir}/include/libcharls directory
|
|
+install(FILES ${charls_HEADERS} DESTINATION include/CharLS)
|
|
+
|
|
+
|