You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Box2D/Box2D-2.2.1-unbundle-freegl...

45 lines
1.2 KiB

--- CMakeLists.txt~ 2011-03-06 18:29:20.000000000 -0600
+++ CMakeLists.txt 2012-07-28 14:23:58.712181310 -0500
@@ -25,7 +25,7 @@
# Testbed and dependencies.
find_package(OpenGL REQUIRED)
- add_subdirectory(freeglut)
+# add_subdirectory(freeglut)
add_subdirectory(glui)
add_subdirectory(Testbed)
endif(BOX2D_BUILD_EXAMPLES)
--- Testbed/Framework/Render.cpp~ 2011-09-11 20:52:20.000000000 -0500
+++ Testbed/Framework/Render.cpp 2012-08-02 10:20:24.235457638 -0500
@@ -21,7 +21,7 @@
#ifdef __APPLE__
#include <GLUT/glut.h>
#else
- #include "freeglut/freeglut.h"
+ #include <GL/freeglut.h>
#endif
#include <cstdio>
--- Testbed/Tests/TestEntries.cpp~ 2011-09-11 23:55:26.000000000 -0500
+++ Testbed/Tests/TestEntries.cpp 2012-08-02 10:22:09.535455225 -0500
@@ -22,7 +22,7 @@
#ifdef __APPLE__
#include <GLUT/glut.h>
#else
- #include "freeglut/freeglut.h"
+ #include <GL/freeglut.h>
#endif
#include <cstring>
--- Testbed/CMakeLists.txt~ 2011-09-06 17:47:48.000000000 -0500
+++ Testbed/CMakeLists.txt 2012-08-02 10:26:16.954449762 -0500
@@ -85,7 +85,7 @@
target_link_libraries (
Testbed
Box2D
- freeglut_static
+# freeglut_static
glui
${ADDITIONAL_LIBRARIES}
${OPENGL_LIBRARIES}